Suzuki FZ50 will not keep running after start

Chris Henige /

Got this old 1980 Suzuki FZ50 back together. It starts up pretty well with full choke and just a little gas. It runs for a few seconds and sounds pretty good but then stalls out.

Any hints on what to do next?

Re: Suzuki FZ50 will not keep running after start

Clean the carb . All passages need to be every clean , clear through from entry to exit .

Re: Suzuki FZ50 will not keep running after start

Need more info. What have you done trying to get it running, as per Fred’s Guide? New plug? Any new gaskets? Using premix? I also have an FZ50–is yours complete with the original petcock and oil pump? Just FYI, I had to test my engine with an external tank using premix after I cleaned the carb and ignition system components (flywheel and stator coils).

Re: Suzuki FZ50 will not keep running after start

I have one and if you look at the bowl there are little passageway that need to be cleaned with a tiny wire or air .. also clean the jets really good I bet it's that dirty ..

Re: Suzuki FZ50 will not keep running after start

Chris Henige /

Ok, looking at carb. Fuel is dripping out of a brass tube on the bottom. Is this an overflow for the bowl? Also will only start with starting fluid in intake. So looks like not getting fluid.

Re: Suzuki FZ50 will not keep running after start

Chris Henige /

Also what is the tube fitting at the back top of the carb? Mine has a bolt in it.

Re: Suzuki FZ50 will not keep running after start

Chris Henige /

Ok it is supposed to back to the petcock which I do not have. Overflow?

Re: Suzuki FZ50 will not keep running after start

> Chris Henige Wrote:

> -------------------------------------------------------

> Ok it is supposed to back to the petcock which I do not have. Overflow?

You're saying you have no line going from the petcock to the carb at all? If you already have a fuel line, it sounds like that's a vacuum line

Re: Suzuki FZ50 will not keep running after start

Chris Henige /

Summary

Does not have original petcock.

Only one line goes from gas tank to carb.

“Return” line is capped off on carb.

Have completely gone thru and cleaned carb.

Fuel is leaking out of float bowl overflow On bottom of carb if I leave peacock on.

Will start with starting fluid and runs too fast for about 5 seconds and then stalls. Choke on.

Last year it ran well. Only change is we added back oil pump system.

Re: Suzuki FZ50 will not keep running after start

What you have capped is a vacuum port .

The reason it's leaking out the drain/overflow is probably because the float valve is dirty and possibly defective .

Polish the float valve seat with q tips and Brasso or the like until it's shiny bright .

Check the tip of the float needle for any deformity . It should be smooth and conical .

Insure the float actually floats , is serviceable and the height is set correctly .

Bookmark the Parts breakdown use it often :

https://www.partspitstop.com/oemparts/l/suz/50d3ec04f8700230d8b4b094/1980-fz50-parts

Download and become best friends with the Service manual :

https://www.manualslib.com/manual/827181/Suzuki-Fz50.html

Re: Suzuki FZ50 will not keep running after start

Chris Henige /

what is the vacuum for?

Re: Suzuki FZ50 will not keep running after start

> Chris Henige Wrote:

> -------------------------------------------------------

> what is the vacuum for?

The automatic fuel valve , which you don't have , anymore .

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account