NU50M Battery not charging

The bike isn't charging the battery (12v 3.5Ah) I replaced the recitifier and stator and still the bike isn't charging the battery. I'll ride it and use up the juice in the battery with the lights etc then charge it back to 12v so my guess is it isn't the battery esp since its new. The turn signal relay makes a weird clicking noise, could that be causing a short of some sort?

Re: NU50M Battery not charging

It will always click with the blinking of the lights. Are your bulbs the proper wattage?

Re: NU50M Battery not charging

I just discovered it's not the turn signal relay but the starter relay. Could that be causing my problems?

Re: NU50M Battery not charging

Downhill Harvey (OFMC) /

Do you have a voltmeter? Start the bike and test the battery voltage, rev it up, and it should hit at least 13 volts.

Re: NU50M Battery not charging

Shawn Manthey /

Reviving/ stealing an old thread here. I'm having issues on my nu50m like the OP. Starts and runs fine. Lights work but the battery isn't charging. Reving it up doesn't change a thing. I can charge the battery with my charger and it will last until the lights and starter run the battery down to nothing. Any suggestions? Thanks

Re: NU50M Battery not charging

Captain Janeway /

On mine it was because it had a bad regulator.

Re: NU50M Battery not charging

Shawn Manthey /

Thanks, I'll look into that. Time to get the manual out.

Re: NU50M Battery not charging

Captain Janeway /

The Urban manual is so detailed. I love it. Some of the other Honda manual aren't good that way.

Re: NU50M Battery not charging

Shawn Manthey /

So ive gotten back to tinkering on the charging issue again. Replaced the regulator and that didnt change a thing. Swapped the stator out with a known good one and that didnt change anything. Tried swapping out the flywheel cause I had another one laying around and I figured why not, nothing. Looking at the wiring diagram it looks like some wires from the stator goto the cdi. Is it possible that the cdi is my problem? Anyone have any ideas? All inputs greatly appreciated.

Re: NU50M Battery not charging

Short of some possible bad wiring , that's about the only thing you haven't replaced .

Re: NU50M Battery not charging

Shawn Manthey /

Do you think that something in the cdi is causing the problem?

Re: NU50M Battery not charging

Without testing each component , I couldn't tell you .

Re: NU50M Battery not charging

Shawn Manthey /

So I just tested the stator that I had previously tested good. Checked for resistance between the black/red wire from the stator to ground and it no longer has resistance like it used to. I checked my old stator and it currently reads exactly the same. I'm thinking that this stator is bad now. Is there anything that would cause the stator coil to go bad like that?

Re: NU50M Battery not charging

Coils don't go bad from not being touched .

Like I said , test each component . That means each individual piece . Each coil should have a given resistance .

Read / use section 13 of the manual to find all those values .

Write each down until you've checked everything separately .

It should become apparent what the problem is .

Re: NU50M Battery not charging

Shawn Manthey /

So I checked the stator, cdi, and voltage regulators. The stator and cdi check out good per the manual resistance specs. Both the old and new voltage regulators test out of spec. Reading 250k ohms where it should be 1-5k ohms. Do you think its possible that even though its listed for a nu50m that the voltage regulator is wrong? Any suggestions on a correct one if thats the case? Was reading into the full wave trail tech one, does anyone have any pros and cons on that? Thanks for all input

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account