Stumped 1979 Yankee Peddler custom with no spark.

I have no clue what the issue could be. I've redone all the wiring with new cables and completely rebuilt the engine. It originally needed the rebuild due to a busted bearing. But now I have zero spark. I've replaced all the components with new ones and still no luck. Idk if it's timing or what but I am getting absolutely zero spark. I'm in Northern California between SF and Sacramento and if anyone can help either here or in person I would be happy to supply beer, travel (reasonable distance) and even pay a little to get my bike on the road. Picture of bike included.

IMG_1424.jpeg

Re: Stumped 1979 Yankee Peddler custom with no spark.

Brandon Weiss (Detective brandon to you) /

Clean your points, gap them to spec, and check grounds/wiring. I'd replace the condenser if you havent.

I think for v1 you just have to ground the blue wire from the stator to test for spark? Someone correct me if im wrong

Re: Stumped 1979 Yankee Peddler custom with no spark.

Unhook your kill switch wire. Could be grounded.

Re: Stumped 1979 Yankee Peddler custom with no spark.

Check the tail light

Re: Stumped 1979 Yankee Peddler custom with no spark.

Richard Eberline /

Inline Junction (like a safety fuse made with wire) found this on a AMF 140.

Check all wires for breaks.

Re: Stumped 1979 Yankee Peddler custom with no spark.

Honda scrambler fuel tank?

Re: Stumped 1979 Yankee Peddler custom with no spark.

Glad this bike still pops up. Poor things been through a lot over the years. I second checking taillight and make sure all grounds are on bare metal. Double check the spark plug boot and wire connections, they can come loose and kill spark.

Good luck!

« Go to Topic — end of thread

Want to reply to this thread?

We'd love to have you join the discussion, but first you'll need to login (or create an account).