82 Towny wont rev,stuck in "start" mode !

Danny Warner /

At my wits end here! ive redone many scooters in the last 10+ years..but this is as frustrating as it gets. bought used off a guy who was basically going to scrap it, so i felt i did a good deed saving it! ill give a brief history...

helluva mess when i got it but it kinda ran, think guy was done with it as he couldnt get it to rev. bike has new charge coil, and ign coil. Carb and all cleaned and good to go. at one point outta the blue it revved up and ran great for about

2 mins, but as soon as the rpms dropped to idle, it wouldnt rev again.

Ive tried removing the control unit and running it, dissambled the "off start run" key switch and cleaned and lubed. hell at one point i had the whole key switch box on the bench and still nothing( thought maybe that would bypass everything and give it its full rpms) all wiring has been inspected as well.

The ONLY time it revved up is when i momentarily grounded the single black wire ...from the bike to the control unit... with a screwdriver to the frame, and boom! lit right up!( after a spark or 2 from grounding it out) the wire is beside the 4 wire harness that plugs into control unit, the black wire also hooks up to the control unit but is not in the harness, its separate. unfortunately parts are pricey for this bike as far as electronics. had plans of doing a decent resto on it and moving it along in hopes of getting another Honda express nx 50, but i kinda like the thing! will prob end up with another scooter haha... the bike is looking great now, just not running to swell... any input would be appreciated

Re: 82 Towny wont rev,stuck in "start" mode !

Danny Warner /

sorry, its a 1982 yamaha Towny with the dreaded 3 position key switch...

Re: 82 Towny wont rev,stuck in "start" mode !

Jack Rutherford /

I had same issue. Replaced the charge coil and that did the trick. Did you use the pw50 charge coil? Or what charge coil did you use to replace the original?

check your spark as well. You want a nice consistent blue spark and not a weak intermittent yellow one. If spark is suffering, I would troubleshoot the whole chain - plug, boot, ignition coil, cdi, etc.(edited)

Re: 82 Towny wont rev,stuck in "start" mode !

Danny Warner /

I ended up with a "over seas" Ebay stator plate and used charge coil off of it, supposedly a direct fit for a QT 50 , had to do some light soldering. after installation, it seems to have had tons of spark..at one point I lost all spark, that's what made me replace it. I saw nos Yamaha coils but were 80 -100 bucks.. so I went Chinese..

Re: 82 Towny wont rev,stuck in "start" mode !

Jack Rutherford /

I used the pw50 knock off stators and took the charge coil off of them. I found out that they are a direct fit but you had to flip the charge coil over and connect the ground as it was connected on the qt50 to the light coil for it to work properly on the qt50. I had one that worked for a little while and then fade because I didn't install it properly. same process on mj50

pw50 stator conversion(edited)

Re: 82 Towny wont rev,stuck in "start" mode !

I seem to remember a few years ago I noticed that my '82 Towny would rev and run even when the key was in the "start" position. It turned out that a multi-connector plug, residing behind the black plastic below the speedometer, had become unconnected. And, if I'm remembering correctly, I think I didn't even need the key to be turned on for the bike to start and rev/run. You might want to try unplugging your connector and see what happens.

Re: 82 Towny wont rev,stuck in "start" mode !

Danny Warner /

like i say, i have tons of spark..esp with the new Chinese coil, i considered a pw50 coil,but ended up with the qt50 coil, i was gettting a yellowish spark when i 1st got the bike, then i lost all spark..got new coil and got bright blue arc.. i will check,now that its been running for 20 mins on start mode, to ensure its still a pretty blue.

Den 23, i have tried your advice as well, ive had every combo of harness, plug , wire hooked and unhooked in some fashion! it just wont throttle up!

I find its odd, that it does try once in awhile when i ground the black wire from the bike to the control unit, im sure thats telling me something...ugh... no more Yamahas for me! ( as i look on Craigslist at Yamaha scooters) haha

Re: 82 Towny wont rev,stuck in "start" mode !

Jack Rutherford /

Get a timing gun and check the timing. I know it is "fixed" but if your pulse coil or cdi is bad, timing will be off.

Re: 82 Towny wont rev,stuck in "start" mode !

I'm about to get one of those PW50 knockoff stators in the mail soon. Changing mine on my 84 is a must. My spark sucks and now it's to the point where it can't even get a good run going. I even put a clone carb on it and got a good week out of it but after that spark changed its normal color.

Is there a better guide than the picture that we can find from QT50.Net? my brain is all over the place with this and that I just don't want to fuck it up. I love this machine. More so, because I've given this to my girlfriend and she loves it more than I did. I'm running around with one of those zeda 80 motors on a bike until I can get another QT

Re: 82 Towny wont rev,stuck in "start" mode !

Danny Warner /

sorry for no updates, but i ended up ohming out the " Chinese" coil i got with a overseas stator plate. the ohms jumped around some (and i didn't have my fingers on the leads) ,i didnt really think much about it.. i installed it anyway, and it never did rev out...just stayed in the retarded spark mode. so as a last ditch effort, i got a pw50 performance coil,for $21, and it fired right up!! steady ohms at 272... or maybe it was 256? i dont really remember, but didnt fluctuate like the chinese one did ... so its running, the 3 way key magically works great now. i m in the process of cleaning and painting her up!

« Go to Topic — end of thread

Want to reply to this thread?

We'd love to have you join the discussion, but first you'll need to login (or create an account).