Re: Polini E50 won't idle, poor performance, white smoke

glad u found the problem, i was getting depressed.

Re: Polini E50 won't idle, poor performance, white smoke

The moped is running the best it has ever. I got a vm20 and estoril pipe and changed the gears to 16/40 from 14/45. The low end is impressive - pulling the front wheel off the ground but I took a hit on the top end - maxing out at high 40s. The moped was previously going 55+ with the 15 bing and boss pipe but was a slug off the line.

I haven't played with the jetting for the carb yet. I am running the stock 180 main, 25 idle. If I went to 18/40 gearing would I get more out of the top end or should I put in a bigger jet?

Re: Polini E50 won't idle, poor performance, white smoke

180 is probably too rich IMO

Re: Polini E50 won't idle, poor performance, white smoke

What would you recommend Boyd?

Re: Polini E50 won't idle, poor performance, white smoke

Actually I take that back.

I run a VM22 on mine and the jetting is a bit different, but I think it's a little under 180 with a malossi 4 petal and MLM cali pipe. I can look later today, I haven't touched it in years.

I see one entry on the tuning spreadsheet that shows someone running a 185 on a polini, so you might be in the right range. I'd try going up and down some main jet sizes and seeing where you land.(edited)

Re: Polini E50 won't idle, poor performance, white smoke

Okay thanks.

I went about ten miles and the plug is pretty dry. I think I will upjet

« Go to Topic — end of thread

Want to reply to this thread?

We'd love to have you join the discussion, but first you'll need to login (or create an account).