Qt50 ignition coil

Spring is here....and I have no spark on the qt50. There is compression and gas is flowing. It ran last week although not flawlessly. There were major misfire issues and problems ideling without throttle attention. Since it rolled out of my dads barn my buddy and I did minor upgrades like throttle and choke cables, fuel filter, carb cleaner, new hoses, battery, bulbs. Last week when It was running obviously there was spark, but still needed 30 cranks to get some life out of it. Seems like the next reasonable step would be to get a ignition coil. Any opinions and advice on my logic and reccommendations on aftermarket parts as I don't see anything original that would make sense?

Re: Qt50 ignition coil

Jack Rutherford /

charge coil in the stator is usually the problem but try taking your spark plug boot off and cutting 1/4" of the ignition coil off to get back to good wire. screw boot on and see if that helps.

Re: Qt50 ignition coil

I used a coil for a blaster.

Bolted right up, works fine.

Coil

There are hopper coils on eBay.

Coil part deux.

Re: Qt50 ignition coil

Have you tested the coil using your multimeter? If your coil is configured with one wire or lug and uses the bracket as a ground like this one...

coil.jpg

...one reading should be around 1.6 ohms and the other should be around 6600 ohms. Please report back your figures.

Re: Qt50 ignition coil

Louis Brunskill /

Charge coil... and don't forget old dead reeds and hard crank seals as suspects...

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account