Re: Puch 1977 - Hard to Start // Revs High // Stalls

Tyler Durphine /

Cable length was fine before. Adjusted a bit. Thinking I can just move the needle down. That would help lower the slide correct?

Re: Puch 1977 - Hard to Start // Revs High // Stalls

Incorrect. The only two things that position the slide are the throttle cable and to a lesser degree the idle screw

Edit- unless you think the needle itself is getting stuck in the emulsion tube. In which case, fix that instead of moving the needle position. If you take your main jet out and the needle is out, how does the emulsion tube look?(edited)

Re: Puch 1977 - Hard to Start // Revs High // Stalls

Tyler Durphine /

Thanks for the info. Entire carb is super clean. I’ll fiddle with the throttle cable then. But it appears open right?

The needle has been in the same position when it ran well. The throttle cable has been played with a bit.

The the knarp on the throttle cable should go all the way through the hole in the slide and move over to lock, correct?

Re: Puch 1977 - Hard to Start // Revs High // Stalls

Your slide is half way up. It is either the idle screw is cranked super far in or the cable is too short.

Re: Puch 1977 - Hard to Start // Revs High // Stalls

Tyler Durphine /

HAS to be cable. Had issues with it before and am going to replace the entire thing. I can remove the idle screw completely and it still stops at the same position.

Re: Puch 1977 - Hard to Start // Revs High // Stalls

Tyler Durphine /

BOOM. should be good. Adjusted cable more. Everything seems to work will test ride tomorrow. Thanks all!

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account