Puch maxi cuts out at low RPM

I have a e-50 puch maxi with a 70cc K-Star kit, a techno circuit exhaust, and a 16:14 Dellorto carb. It currently has a 78 main jet. I hadn't ridden it in over 5 years, and it was running fine when I put it away.

Yesterday, my friend and I tuned it up (cleaned the carb, gapped the plug, checked all the wire connections) and got it to fired up, but it won't idle at all. It will stay running at 1/3 throttle or more but immediately cuts off at anything below that.

Fairly thick smoke was coming out of the exhaust, so I think it's running a little rich. It was also a very humid day, but those things combined shouldn't prevent the bike from idling.

To give a little more context, it was harder to start the bike with the choke on, which leads me to suspect it wasn't getting enough air. With that said, it was not four stroking at WOT.

Does anyone has any insight into what's going on?

Re: Puch maxi cuts out at low RPM

Louis Brunskill /

Did the idle jet get put back in it.. or maybe it was left loose?

Re: Puch maxi cuts out at low RPM

I've adjusted the idle jet and that doesn't seem to make any difference

Re: Puch maxi cuts out at low RPM

my 1st worry is your trans fluid.

Re: Puch maxi cuts out at low RPM

5 year old gas?

Re: Puch maxi cuts out at low RPM

u probably sucking/burning oil from clutch side crank seal. maybe itll loosen up after a few heat cycles.

Re: Puch maxi cuts out at low RPM

Naw, fresh squeeze

Re: Puch maxi cuts out at low RPM

Tell me more? How can I check this?

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account