NC50 electrical stuff

Hello all (especially expressos such as myself)

Just finished with some light modification on my 78 express (changed tranny oil and swapped to dellorto SHA 15.15 with premix, new tires), found that it doesn't have spark. I am fairly certain the spark plug is fine since it shocked the shit out of me about a month ago when I was checking the compression. I know that there are threads about this already, I am just very very apprehensive about working with electronics because I know so little. What's the electromagnet thing under the flywheel bell thing called? whats a stator? what is a dynamo? If there are 3 things about the electronics on this bike or any bike that a caveman would need to know in order to get spark, what are they? I have been dreading the moment I deal with the electrical loom (if you could even call it that) since I bought the bike but the moment has come. Thanks for any help!

Re: NC50 electrical stuff

#1 - change your plug. 1st thing every time, even a perfect looking plug, do not waste any additional time on anything else until you're sure it's not the plug. so many timesso many of us disassemble all kinda of shit and then all we had to do was swap the plug. learn from others mistakes!

#2 - disconnect any kill switch. This is not always super obvious especially with a CDI, but 78 you're still points (right?). it is a quick check to make sure it's not just the switches stuck turned to off. You should be able to trace the plug cable back to the HT coil. There's a wire outta the coil to ground (green?) and a wire coming in that's maybe black and white. trace that black and white wire to any connectors, disconnect anything except directly the black and white directly from the engine

#3 - clean the points. look up fred's guide in the wiki, there's details in there.

#4 if still nothing try tracing it back from one end or the other. a multimeter will help. check you get power out of the engine on the black/white wire, just the wire itself disconnected from everything outside the engine. if no, you know it's in the stator (probably points). if yes power outta stator, check that it's getting power to the coil, check the plug wire with the boot disconnected etc on down the line til you identify where the break is.

Re: NC50 electrical stuff

Could be your spark plug cable and/or boot. Have you replaced them? You could try cleaning inside of the boot with electrical cleaner, and clip a small chunk off of the end of the cable and re-attache the boot... couldn't hurt.

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account