Low compression pa50I

I have a stock pa50I . I did a compression test and I got 25psi. So order a new piston,rings and gaskets. I put it back together with all the new stuff without the ring expander cause the piston wouldn't go into the cylinder with it on. I did another compression test and I'm getting 15psi. What could be the issue

Re: Low compression pa50I

Maybe your compression tester ?

Re: Low compression pa50I

Pedal or drill start it for a while and see if compression climbs. Then I guess u need to assess the decomp. One easy way is to mix a bit of baby shampoo in a spray bottle and then spin engine and see if soap bubbles form at the site of a leak which could be the head gasket, a warped head, I guess wrong rings , decomp valve.

Re: Low compression pa50I

It's not the compression tester cause I've used it on my yz125

Re: Low compression pa50I

> Jakob N Wrote:

> -------------------------------------------------------

> It's not the compression tester cause I've used it on my yz125

That proves nothing , other than your using it on a different bike .

Re: Low compression pa50I

Please do the bubble spray

Re: Low compression pa50I

> Marc Friedman Wrote:

> -------------------------------------------------------

> Please do the bubble spray

This ^ . You can use a heavy mix of dish soap and water , too .

Re: Low compression pa50I

There is two position two put the piston in and also make sure the ring’s slot are not facing the wrong way as well. Do a goggle on you tube you will see. Just did this one. 1982

411CF948-1309-4B42-9626-2A397A4E129A.png
« Go to Topic — end of thread

Want to reply to this thread?

We'd love to have you join the discussion, but first you'll need to login (or create an account).