Morini M1 - No pedal assist?

Hey all,

Have a very low mile M1 that starts, idles, revs, etc, fine. All stock. Never been messed with or had the cases opened.

Once running, if I pedal forward the shaft just spins (doesnt "grab" and makes a low "clicking" noise. If I don't pedal forward there is no noise. Freewheeling backwards is fine as well. Is this normal? Im used to being able to pedal off the line with my Puch / Tomos. Any ideas what could be causing this?

Thanks

Andrew

Re: Morini M1 - No pedal assist?

Once the engine runs, the pedals aren't needed until you go so slow,say 6 mph on a hill, and then they'll engage. Also, do not use the starter clutch lever except when you start it, never while it's running.

Re: Morini M1 - No pedal assist?

Yes I know that after a certain speed the pedals do not "engage" any more or add anything in the way of propeling you forward and spin freely. My concern is that while on the kickstand or at a stop the pedals do not "engage" when I rotate forward. I'm curious as to whether something inside the transmission could cause this?

As I said, I have no problem pedal starting the motor and the pedals "engage" from a stop when the motor is off.

Thanks

Andrew

Re: Morini M1 - No pedal assist?

Don - I will PM you a video of the problem I'm having when I get home

Re: Morini M1 - No pedal assist?

Hmmmm..... I've never had that happen. I won't be online here until after 9 PM. I am working on my Lincoln LS valve cover replacement and reinstalling everything on top including the upper intake manifold. Here is a manual from Marty's:

https://martysgarage.info/manuals/moriniservice.pdf

Re: Morini M1 - No pedal assist?

Benjamin The Wandering Pacer /

Andrew, are the pedals engaging at any point?

Re: Morini M1 - No pedal assist?

> Benjamin The Wandering Pacer Wrote:

> -------------------------------------------------------

> Andrew, are the pedals engaging at any point?

I think he left us when he got the service manual, Benjamin. LOL!

Re: Morini M1 - No pedal assist?

Benjamin The Wandering Pacer /

> Don Ohio Wrote:

> -------------------------------------------------------

> > Benjamin The Wandering Pacer Wrote:

>

> > -------------------------------------------------------

>

> > Andrew, are the pedals engaging at any point?

>

> I think he left us when he got the service manual, Benjamin. LOL!

Highly possible. I was wondering if it was an internal chain issue.

Re: Morini M1 - No pedal assist?

Haha, sorry guys been really busy with work and school. Fixed the issue. Turns out the idle was super high and the internal gearing on the pedal mechanism is much shorter than what I am used to on my other mopeds. For example, I can pedal assist my Magnum until about 10mph. The sebring pedal assist off the line becomes ineffective past 4 or 5 mph.

Thanks for the help!

Andrew

Re: Morini M1 - No pedal assist?

You're welcome. Glad you figured it out! Yes, Puch pedals much better than Morini.

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account