Trac Escot 1986

William Trainer /

Hi, have a Trac Escot, 50cc. After sitting for a while I emptied the carb bowl, put in fresh gas and checked the oil. When taking the carb off I took the top off and ended up putting the throttle linkage back in wrong.. it started and went to full throttle!! I drove it around the block and it ran really quick!! got home and corrected the linkage and now it will start with the choke and run a couple seconds then quit. If I block the air intake it will run without quitting but the moment I uncover the intake it quits. I have disassembled the carb and cleaned everything, it is getting gas and oil to the bowl, the float and seat are fine. Frustrating because it did run great at first - any suggestions on what to troubleshoot? thanks Daelim motor and Mikuni carb.

Re: Trac Escot 1986

Sounds like you didn't clean the carb good enough .

Every passage has to be pristine . Use brake cleaner through all passages and insure the cleaner comes out where it's suppose to .

Re: Trac Escot 1986

William Trainer /

Hmm, I used carb cleaner in all the ports as well as a wire. Removed both jets and made sure they were clear. It pulls gas with the air port closed but doesn't seem to otherwise. I can clean again with brake clean but feel like something else is going on. thanks

Re: Trac Escot 1986

It's likely pulling fuel via the choke . Your hand on the intake is a poor man's choke .

Be sure you have the throttle cable hooked into the slide properly .

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account