Re: No power - Vespa Piaggio SI

Kristian Lomeland /
This single post is part of a larger thread. Start from the top or view this post in context.

> Dirty30 Dillon Wrote:

> -------------------------------------------------------

> Looks like your belt is not adjust correctly and the belt's spinning on

> the rear cheeks.

The rear cheeks are spinning, but the clutch housing i shaking like crazy.

> Ike Pipe Wrote:

> -------------------------------------------------------

> If the upjet doesn't work, I'd revisit the leak down. What method did

> you use?

Okay. I plugged up exhaust and intake. Then i screw in a custom air coupling that i’ve welded to correct thread to go in the spark plug hole. Then i hook up the air and have 4 bar on the dial. Then i go over hearing and using soapy water to check for leaks.

> pat splat Wrote:

> -------------------------------------------------------

> i hear a clickity clickity sound, kinda like a sloppy piston or needle

> bearings in the rear pully or... take off the belt and feel for

> rubbing/smoothness.

Yes, I hear it too. I have no idea where it comes from. There is a new piston and rings in it.

Does the pulley have bearings also? It feels smooth and easy when turning it by hand.

The belt gets wounded a bit, but cant feel any issues with either front- or rear variator smoothness

This single post is part of a larger thread. Start from the top or view this post in context.

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account