E50 ignition cutting out at medium to high revs

Hello.

My E50 is cutting out at high revs, it's definitely ignition as I can hear a pop on occasion. It has the standard points ignition and changing the plug hasn't made a difference. Ive disconnected the grounding wire to eliminate that and no difference. Guessing what's left are the HT coil, condenser and points so will start swapping them out. Just wondered if anyone had an idea what I should swap first, I'm thinking condense.... cheers!

Re: E50 ignition cutting out at medium to high revs

you need a new condenser and you might as well do the points while your at it.

Re: E50 ignition cutting out at medium to high revs

Overpriced Parts /

You probably don’t need nothing but maintenance,

Read this completely especially the part 3/4 of the way down on page

https://www.mopedarmy.com/wiki/Puch_timing

Re: E50 ignition cutting out at medium to high revs

Thanks Jeff

Re: E50 ignition cutting out at medium to high revs

Thanks Ken

Re: E50 ignition cutting out at medium to high revs

Hello chaps.

I have replaced and gapped the points, checked timing OK at 17 degrees BTDC, replaced condenser and also tried swapping out the ignition coil, spark plug and spark plug lead and cap. I have checked the condition of the stator wiring and disconnected the kill wire from the kill switch.

It is still cutting out. What I notice is when it does, I only get the ignition back if I ease off the throttle, if I open the throttle more then it won't come back. I know this symptom kind of point to fuelling but it is definitely ignition (good pops out of the exhaust when it happens).

Any ideas?

Thanks, Rich.

Re: E50 ignition cutting out at medium to high revs

♣Slew Foot♣ /

Did you run it in the dark w/o covers?...

Re: E50 ignition cutting out at medium to high revs

Hello slew foot, why do you ask? Cheers.

Re: E50 ignition cutting out at medium to high revs

did you ground your ignition coil?

Re: E50 ignition cutting out at medium to high revs

Yeah it's grounded, it's the european style ignition 2 lighting coils and ignition coil all mounted to the stator plate as shown in attached photo. Cheers.

20200616_161854.jpg

Re: E50 ignition cutting out at medium to high revs

I think Slew was asking because a failing condenser can cause arcing at the points, which would be noticeable in the dark.

Re: E50 ignition cutting out at medium to high revs

get some og points, lube the cam n felt too.

Re: E50 ignition cutting out at medium to high revs

Andrew Fleetwood /

Swap the plug cap and see what happens. These break down on air cooled engines, and was the most recent cause of breakdown on mine with the exact same symptoms as yours. I now carry a spare....

Re: E50 ignition cutting out at medium to high revs

Is your neck tight? Is ur front fender touching the plug boot and shorting it out?

Re: E50 ignition cutting out at medium to high revs

Thanks guys for the pointers.

I exhausted all avenues with the ignition, then decided to revisit the fuelling and removed the 15mm Bing and put a 17.5mm Dellorto PHBG from another moped on it, the issue has gone and now it rips. Had a quick look and looks like the Bing float needs some adjustment or I get another Dellorto as it is so much nicer!

Cheers, Richard.

Re: E50 ignition cutting out at medium to high revs

Pushrod Fifty /

Had those symtoms when I put a piston in upside down once. Also had popping sounds at deceleration when my carb was too lean.

Re: E50 ignition cutting out at medium to high revs

yeah I've also experienced popping with a mikuni vm when the needle is very lean

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account