I rebuilt my Za and now it sounds like shit

Wesley Ambrosini /

So this is it running without the trans.

I had a new rod pressed in

Crank ended up measuring cheek to cheek as close to my old crank as I could accurately measure with my calipers.

Reassembled to case, stock thickness gasket, tourqued the case bolts.

Put the motor in a vise, used machinist dial, couldn't get an accurate reading on the play, basically zero. Crank feels smooth no binding

Put on a kit directly off my e50 that this motor is replacing.

This is the motor, rope started, with no trans parts in it

Anywho just listen to this shit

Re: I rebuilt my Za and now it sounds like shit

You sure the flywheel is torqued? Everything ok behind it? How does it now spin by hand?

Re: I rebuilt my Za and now it sounds like shit

Wesley Ambrosini /

Flywheel is torqued and I just lapped it

Spins great with the top end on and off. Like perfect.

I knew the rebuild went too smooth my first thought before I started it was "I don't know what all the fuss is about za rebuilds aren't so bad"

Re: I rebuilt my Za and now it sounds like shit

What if you removed the flywheel, took out the plug, spin it with an electric drill and check run out on the crank? Maybe uncle Ken knows what's up?

I just rebuilt one of these too. Haven't fired it yet. Hope I'm not in the same boat. Hope you get this sorted. (edited)

Re: I rebuilt my Za and now it sounds like shit

Wesley Ambrosini /

Something is going on with the flywheel. I must have have put it on like a jackass in a rush because even lapped it sheared the key not its out if round as fuck. With the flywheel off its smooth with it on it hits and grinds

Re: I rebuilt my Za and now it sounds like shit

Nice! Glad you found it. Shit happens. I did something similar with a Tomos but was able to salvage it.

Re: I rebuilt my Za and now it sounds like shit

Maybe without the trans it is unbalanced? Hook it all up and try again? No resistance may lead to noisy play?

Re: I rebuilt my Za and now it sounds like shit

How close did you get the crank to true? How did you true it? Did you replace both bearings? You have to replace the inner and outer races not just one

Re: I rebuilt my Za and now it sounds like shit

Wesley Ambrosini /

The crank was sent to Mr. crankshaft so it was trued and polished and all that shit.

The roffman method is run it without a trans so I don't think it would goof it up.

Yeah I replaced the outer races and cages the whole deal

Re: I rebuilt my Za and now it sounds like shit

I’m guessing your shimming is off then. Take it apart and fix it!

Re: I rebuilt my Za and now it sounds like shit

Wesley Ambrosini /

> Daniel '' Wrote:

> -------------------------------------------------------

> I’m guessing your shimming is off then. Take it apart and fix it!

That's what I'm thinking. It has zero wiggle, doesn't bind, I thought I lucked out but I guess not.

Re: I rebuilt my Za and now it sounds like shit

Overpriced Parts /

Yeah that seems like somethings out of whack! did you drop your crankshaft!

how does the crank look on the inside trans side? Is there a proper clearance between the lobes and the crank and the crank case?

Does it have zero wiggle When running,

Is the top end perfect at the crank pin, is the bearing the correct width and size?

Re: I rebuilt my Za and now it sounds like shit

Wesley Ambrosini /

Ok, outta the woods probably

Just got it running.

Looks like a typical chain of errors

So I rattled the flywheel on in a hurry

That destroyed the key

Key chunks got into the flywheel magnets and that was what was chunking

Lapped the crank to a different flywheel

Runs great.

Still have to do the trans end float but at least the crank is OK

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account