Tomos Ignition

Bobby D /
This single post is part of a larger thread. Start from the top or view this post in context.

Hi all, I am fixing up a 93 Tomos Targa LX for my buddy. It had a new 70 cc kit on it but the previous owner never got it running. I cleaned out the carb, up jetted and fixed some odds and ins and it was good as new. I was riding it to break in the new cylinder and after about 4 miles I came down to idle at a stop light and the moped died. I couldn't get it to start. I walked it home and determined that I wasn't getting a spark. I installed a new spark plug. No dice. I took off the flywheel cover and saw that the ignition point was missing a contact on the one side. So obviously I need a new point and might as well get a condenser. I also noticed that the flywheel (IDM 6411) is scored on the keyway fore and aft. See photos.

So that is my situation. My questions are:

Is the scoring on the flywheel normal or did the pin on the crank shaft score this somehow?

Is there anyway to test my ignition coil to confirm it is also working? With a 12v power supply or something? Coil is https://www.treatland.tv/original-tomos-A3-A35-OEM-points-ignition-coil-p/oem-tomos-ignition-coil-219509.htm

Does anyone know which point and condenser I need? I am having trouble distinguishing them. Seems like it might be https://www.treatland.tv/CEV-points-no-wire-p/cev-points-no-wire-410001.htm and https://www.treatland.tv/effe-CEV-condenser-p/effe-cev-condenser-6153.htm

I assume they are all somewhat interchangeable?

20200729_212915.jpg
20200729_212854.jpg
This single post is part of a larger thread. Start from the top or view this post in context.
Subject Written By Posted
  Tomos IgnitionTopic by: Bobby D Bobby D 07/30/20 12:47AM
  Re: Tomos IgnitionRe: pat splat pat splat 07/30/20 04:01AM

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account