Vespa Grande Running hot - suspecting variator issue

My 1980 Grande Deluxe seems to be running hot. I recently put a new AX-39 belt on and I’m wondering if there is an issue with the variator not quite functioning correctly. Often when trying to start it lately, the belt seems to slip just enough that the engine won’t turn over easily. (Variator maybe stuck open a bit, causing the belt not to grip front pulley wheel enough? ) Eventually the belt will tighten enough to make engine turn over and starts easily. After running at about 30MPH for 2 or 3 miles, when I come to a stop, it will stall and seems hot. If the Variator somehow isn’t closing enough, would this cause belt to always be a bit loose and maybe cause engine to rev faster than normal, hence hot running? Thanks for any thoughts or guidance. - John Bergland

Re: Vespa Grande Running hot - suspecting variator issue

Ľ̷̝̽͒i̶̛̼͑͠ȁ̸̧̛̽m̵̻̟̯̀̅ ̷͎̙̽̊F̶̲̺͑̓ F /

Have you checked the condenser if it’s stalling?

Re: Vespa Grande Running hot - suspecting variator issue

Thing i like about vespas is that they have a fan to keep things cool, the tin above the cylinder is necessary. If it revs by itself at idle then check your idles speed screw, if the slide is all the way down and you still cant control speed then suspect air leak, Normally the shim between carb n intake is compromised. Also, jetting, no. of filter screens and running an air box or not affects fuel mixture. with carb off clean out that tiny idle jet hole/passage under the throttle slide.

To tighten the slack in the belt you can grind off the rivets in the subframe and move the whole motor forward to take up slack. Starting should be fairly easy using the decompression lever.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account