Garelli dies at idle when warm.... and then is fine?

So my new to me stock Garelli SSXL starts up great and runs/idles just fine for about 20-30 minutes. Then it stalls at idle and usually won’t want to restart until I let it cool down for a half hour or so. Then it starts right back up and runs and idles great for the rest of the day. It’s done this the last 5 times I’ve gone out for long rides.

Fuel flow seems to be fine. The clutch should be fine. I’m at a loss since it seems to fix itself after a partial cooldown.

Re: Garelli dies at idle when warm.... and then is fine?

Probably a bad condenser. Grab a flywheel puller and remove the flywheel. When you buy your flywheel puller grab a condenser too. You can opt for a more "inline" style condenser and mount it outside your flywheel for easier access in the future. But I find these do not go out often so if you replace the one on the stator plate it should be good for a long time.

Re: Garelli dies at idle when warm.... and then is fine?

Considering today's most excellent quality controls ( LOL ) , I'd be mounting any new condenser outside the magneto . ;)

Re: Garelli dies at idle when warm.... and then is fine?

Dirty30 Dillon /

PD's right, definitely mount outside, especially given the small, super hot flywheel side on the Garelli's.

Honestly, if the bike just won't idle when hot, meaning you can run it at throttle but it dies when you let off, it's a clutch issue.

Rubber expands when hot, same goes for rubber clutches.

Re: Garelli dies at idle when warm.... and then is fine?

I may have missed read that if it does run when warm but just doesnt like to go back to idle...

I have the same issue with both of my garelli bikes. I always need to work my throttle down to idle. Feather it a bit when I come to a stop, but it does idle if you dont just dump off the gas back to idle at a stop.

Mopeds man. Good times.

Re: Garelli dies at idle when warm.... and then is fine?

It idles fine. But I’ll be stopped at a light and after about 10 seconds or so it’ll stall out (again only after about 30 mins of riding). Then it’ll idle fine for the rest of the day after a partial cool down.

I’ll have to play around with the condenser.

With how erratic it goes from running great to stalling randomly I’m thinking maybe a grounding issue?

Re: Garelli dies at idle when warm.... and then is fine?

could be anything, fuel not filling bowl, condenser, rubber crap in oil bath, loose tail light bulb, loose spark plug cap, corroded wire, etc. Best to just go one at a time from easiest to hardest per your personal skills

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account