E50 not running. jetting/clutch? Need advice.

Alright so, I put a 70cc airsal kit with a “bi turbo” exhaust and one of those crappy bing clones. (I got the puch speed kit from dennys cycles). I also have a 12v cdi and Rito race crank. It ran for about 300 miles.(it always ran a little rich I planned on rejetting it eventually just never got around to it) I went up a big hill WOT and then it stopped going over 15 mph. I drained my trans fluid and it was full of clutch dust because I used royal purple ATF and it made my stock clutch disintegrate (something I read out of the puch service manual)

I rebuilt my e50 engine and the bearings were shot because they had gotten gasket maker in them. I replaced the bearings put a new jammer clutch in. Then my engine wasn’t running. I took it all apart again and replaced my clutch bell and main gear because the clutch bell was slightly warped, I think. Rebuilt the whole thing and now it still does not run. I have spark and compression. My crankshaft is not bent and has very little play. Whenever I try to run the engine it detonates and makes some pretty bad noises. I believe the problem is that the jet is too big. But for the few moments that it does run I noticed that the clutch does not seem to engage and that the wheel barely even moves when the engine is at full throttle. I have both the small spacers on either side of my clutch and this is my 4th time rebuilding the engine so I think I did it right however, I am dumb.

What do you guys think? Is my jetting too high, I know I have a shit exhaust and clone bing and that’s probably part of the issue. Thanks for any advice you guys have sorry this was so long.

Re: E50 not running. jetting/clutch? Need advice.

Overpriced Parts /

You may not have a good spark and it may not be in time, those CDI’s are pretty junky you got to have a known working ignition before you proceed with jetting

You got too many variables that you Coulda did wrong, you got a check one thing at a time

Re: E50 not running. jetting/clutch? Need advice.

How do you change the timing on the cdi? I know the pietcards can be pretty crappy, but I thought it starts out retarded and advances the timing for you? Doesn’t that mean I shouldn’t have to mess with timing? Thanks for the help.

Re: E50 not running. jetting/clutch? Need advice.

Alex Fredericksen /

Royal Purple ATF is the jam. Never had a problem it. What springs are in the new jammer clutch? Do have any idea what jet/atomizer/slide/needle combo you have inside the carb? What CDI do you have? Tons of little variables to research.

Re: E50 not running. jetting/clutch? Need advice.

the wiki will show you the way.

Re: E50 not running. jetting/clutch? Need advice.

My guess is your timing is way off. Read how to time CDI in wiki

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account