78 hobbit pa50ii spark issues

So I'm working on getting my hobbit going, it had spark, but the plug was dry so I dropped the subframe and engine and made sure the carb had fuel in it, pulled the intake and checked/cleaned reeds etc. All is well there now, before I put it all back together, I checked for spark with a drill and now I have no spark. I grounded the subframe to the engine and hooked the ignition coil up the same as it was, but still no spark. Am I missing something here? Does it all have to be together to be grounded? I figured a wire would work. And also, my wire loom coming out of the stator is red, yellow, green and black. Are these the correct colors? I was getting spark hooking the black wire up to the ignition coil. I have the pa50 manual and these colors do not match with any of the 25 diagrams in there. God only knows which one I need from the manual anyhow. I found a diagram online and it isn't the same either. I'm just at a bit of a loss here.

Re: 78 hobbit pa50ii spark issues

https://www.mopedarmy.com/w/images/6/64/78hobbitwiring.jpg

Those are the right colors make sure the black one with the yellow band is going to the black on with the yellow stripe down the side coming out of the rectifier

Re: 78 hobbit pa50ii spark issues

basically, black w stripe straight to coil, shoot some premix in plughole n drill start. Highly recommend changing both crank seals, magneto side cam is tricky, clutch variator side you will need a special puller 26x1.5, buy, borrow or make one.

Also highly recommend cleaning carb while its out, pita to remove.

Re: 78 hobbit pa50ii spark issues

Richard Eberline /

Green is your ground. the black with a faint yellow stripe coming out of the stator is a positive ignition hot wire. This B/Y goes to your ignition coil, rectifier, kill switch and ignition switch, Take pictures before you take wires apart and or work on new items.

Re: 78 hobbit pa50ii spark issues

I didn't have the opportunity to take pictures, when I got it, all it was was a motor and frame, no electrical harness or anything. I have gotten everything else either on here or ebay. Thanks for the help.

Re: 78 hobbit pa50ii spark issues

I have spark again! Still dry plug unfortunately so I will probably do the crank seals. The carb is brand new, this is the first time it's been on the bike, but I will disassemble and evaluate that as well. I will probably order new rings and gaskets replace those as well while I'm at it. Might as well do it all now that I'm this far into it.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account