Tomos A35 trouble

So I slapped an a35 onto a Trac Hawk frame and it was doing ok but not great. It was running and getting into second with a lot of struggling but now its just sputtering when I rev the throttle. I (we (everyone at the garage)) thinks its a timing issue but I also am not 100% convinced. Other theory is fuel delivery. Ok so heres what I got hooked up:

Tomos a35 motor

New seals and bearings

Clutch looking decent

Dellorto Sha 15:15

MLM Pipe

Treats 70CC kit with hi comp head

Things going wrong:

Spark plug is wet

bogging/cutting out when you rev

cant really go above 10mph unless with super super light throttle

Jetting is 64 dellorto

Ok so long post (sorry) but this project has been a struggle which has been fun but well ya know frustrating also. Is there something else that could be going on other than timing? Its running a stock a35 stator and aftermarket cdi from Dos.

One of my other theories is that the flywheel is warped cause when I stupidly tried to take it off without a puller it may have warped a bit. Thoughts? oh also here are some pics.

PXL_20210604_025118003.jpg
PXL_20210604_025112925.jpg
PXL_20210604_025104898.jpg

Re: Tomos A35 trouble

oh should also mention...

tried a 58,66,74,78 jet, all felt the same (but a little different) but still the same overall problem

Re: Tomos A35 trouble

Try like a 70 or 72. 66 seems pretty low jetting, and 74+ seems extra big. Timing shouldn’t be off if you have the flywheel pin set on it. Tomos have “fixed” ignitions unlike e50’s.

Re: Tomos A35 trouble

I would inspect the reeds extra closely. If they are not opening and closing properly then it will have a huge affect on the bike running.

Re: Tomos A35 trouble

Thats what I was thinking Garrett, so it should still be running at least decently, i know there is a very tiny room for adjustment on it so should be ok.

Jay, I will check the reeds again, maybe switch it to a carbon fiber one since I'll have it off?

Re: Tomos A35 trouble

Another thing, is your piston in the right way? Is the arrow pointing down towards the exhaust?

Re: Tomos A35 trouble

So whats up withe the duel valve 2 to 1? Get rid of that w just a filter and why is the fuel clear, no oil? So im guessing your float needle is not sealing thus flooding motor. Run it with the petcock off and hear if the motor takes off for a few seconds.

Re: Tomos A35 trouble

> pat splat Wrote:

> -------------------------------------------------------

> So whats up withe the duel valve 2 to 1? Get rid of that w just a filter

> and why is the fuel clear, no oil? So im guessing your float needle is

> not sealing thus flooding motor. Run it with the petcock off and hear if

> the motor takes off for a few seconds.

Likely the petcock with a reserve .

And , the fuel filter is backwards .

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account