Tomos Streetmate Stalled and Locked Up

Hey everyone! I was out with my 2008 Streetmate today when after about 25 minutes of driving I stalled while rolling to a stop. I figured no biggie and tried kicking her back up. After about 3 kicks the pedals completely locked up and I was unable to roll backwards. It wasn't until after I pedaled it home (good thing I was close) that it started to roll backwards again, but the pedals are still locked. I read this could potentially be an issue with the clutch or with a type of spring that works as a part of the kickstart system. I'm excited to understand what could now be wrong with this thing and find a way to fix it :D Thank you everyone for your help so far!

Re: Tomos Streetmate Stalled and Locked Up

Moped Lar (OFMC) /

Sounds like you soft seized the motor. You’re gonna have to pull the head and cylinder off to inspect the piston, rings and cylinder bore. Then you need to figure out why you seized it in the first place to avoid this from happening again. I would start looking at the oil injection system to see if it failed. (edited)

Re: Tomos Streetmate Stalled and Locked Up

Ok so I got the head off and the piston is stuck in the cylinder. I just sprayed some WD40 and am letting it sit for a few hours, do you have any advice on how to unstick it?

C4CFDD65-ADCA-4C60-A436-317F29D3D7DB.jpeg

Re: Tomos Streetmate Stalled and Locked Up

Wd40 or a better penetrating oil (PB Blaster) is a good start. Use a wooden dowel and a mallet to tap your piston loose.

Before you attempt to run it again see if you can find out where the air leak happen to seize your cyl. Probably a base/head gasket. Or somewhere along the intake.

Re: Tomos Streetmate Stalled and Locked Up

Moped Lar (OFMC) /

Re: Tomos Streetmate Stalled and Locked Up

Pistons moving again, but I’m having trouble getting the cylinder off to check things over. Do you have any suggestions? As well as any suggestions on how to check for air leaks without running it? And Just for the sake of information, I’m running an UNI filter (had a mesh filter but performance felt wayyy restricted), 64 main jet and a stock exhaust.

Re: Tomos Streetmate Stalled and Locked Up

♣Slew Foot♣ /

That's a kit. Isn't it like a 64cc.

72-75 jet with hi Flo no airbox.

Re: Tomos Streetmate Stalled and Locked Up

^looks stock to me but super rich.

Re: Tomos Streetmate Stalled and Locked Up

The rings may be snagging in the cyl some place that is not allowing you to remove the cyl. You should be able to pull the cylinder away from the engine case a bit as the piston rotates. Just get it away from the case as much as possible. Using a rubber mallet hit evenly on both sides of the cylinder from behind it to try and knock it off of the piston. You want to have it pulled up as far as possible first and maybe wedge a board between the cyl and case just to keep that separation and keep it tight so there isnt any slop when you hit the cyl.

If it is stuck on this bad,then the cyl and/or piston is probably wrecked. It would be best to just plan on getting a new top end for your bike. Otherwise you will need to spend some time cleaning up the cyl you have, and possibly need to re-hone the cyl.

Re: Tomos Streetmate Stalled and Locked Up

Thank you for the tip, I talked to a local guy who does repairs and he too suggested I get a new top end so I ordered the 70cc airsail kit. Ordered two nights ago from Treatland, am gonna throw it on and keep everyone in here posted. fingers crossed it'll get er going!

Once this kit gets installed I'll be rocking:

70cc kit

UNI Filter

Biturbo Exhaust

and mess around with jets in the high 60's.

Any advice for tuning would be greatly appreciated too!

Re: Tomos Streetmate Stalled and Locked Up

It's currently 49cc, what kit do you mean?

Re: Tomos Streetmate Stalled and Locked Up

Wanted to update everyone.

Cylinder is off. Piston wasn’t moving. I pulled off the right side case to find the transmission in absolute disarray. Metal chunks everywhere, Gears chipped, worn out, out of place, and whatever that metal disk thing is that goes into the clutch bell was completely warped and looks to be the cause of it all. One of the 3 bolts looks to have popped out and hit the case every time it’s rotated, causing it to wear away the metal and throw everything else out of whack. I’ll attach some pics and videos because I don’t know what this part is or where I should go from here but as always, your guys’ advice is greatly appreciated and keeping me afloat here!!!

https://youtube.com/shorts/EbudWN6HRIA?feature=share

https://youtube.com/shorts/1Fh5RLB9vwY?feature=share

Going to post this on it’s own thread because I think it’ll need it haha.

51CB8EB8-09BA-43EF-A883-79D89C18C652.jpeg
« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account