Honda Hobbit PA50II Throttle Response

I bought a Honda Hobbit a few weeks back. I have done plenty of work on cars but never bikes and almost never carbs. I have an issue that when I pull the throttle cable I get the same response across the board. If I pull the intake filter I also get the same response throughout but higher rpm. I think the guy I bought it from had a clone carb put on it. Do I need to look for a new carb, any videos that may help out, any general advice, or abandon all hope ye who enter? Gonna pull it this weekend and clean everything. Should have more info after that.

Re: Honda Hobbit PA50II Throttle Response

Dirty30 Dillon /

Is the bike stock? You didn't provide any details.

Re: Honda Hobbit PA50II Throttle Response

What do you mean by "get the same response"?

There are a couple of guides on the wiki here which might be helpful:

https://mopedarmy.com/wiki/Troubleshooting_guide

https://mopedarmy.com/wiki/Fred%27s_Guide

Re: Honda Hobbit PA50II Throttle Response

The bike is stock. Same response as in no rpm change although a twist of the throttle does open the butterfly on the carb.

Re: Honda Hobbit PA50II Throttle Response

That's called bogging. Your running too lean. Get some bigger jets.

That or you have airleaks

Re: Honda Hobbit PA50II Throttle Response

Or the carb is clogged. Clean it

Re: Honda Hobbit PA50II Throttle Response

I doubt it's running lean if it's all stock. Nick is probably right - dirty carb.

Re: Honda Hobbit PA50II Throttle Response

Run it with choke and see how the bike responds to enriched fuel mix.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account