V1 CDI 2041 wiring question - lights?

Not sure if this question should be in the repair section but figured as the CDI was aftermarket and thus might belong here...

I have the 2041 Pietcard CDI... and for the most part it makes sense.. except for the lights..

If I connect the blue from my stator, to the blue off the CDI it's a closed loop - there's no wire to run to the voltage regulator/lights

Two options as I see it:

1. Run the blue from my stator straight to the voltage regulator/lights and forget the blue on the CDI unit. (This is show in my diagram)

2. Connect the blue off the stator to the blue from the cdi box and splice in another wire to the voltage regulator/lights. (Not really sure what this accomplishes - other than connecting them because I feel like I am supposed to).

Appreciate any insight - especially those who are currently running this CDI with lights.

Re: V1 CDI 2041 wiring question - lights?

blue from the stator (if it's the pietcard coil) should go to the blue on the pietcard cdi box. you should have swapped your ignition coil over as your lighting coil that way you get 12v lights... and it's as easy as just moving the coil and running the lights off of the hot wire from that coil.

the pietcard coil does not have a wire just for lights.

Re: V1 CDI 2041 wiring question - lights?

Are you still active on this forum? I have some questions about the Pietcard set up I was hoping you could answer. Thanks!

Re: V1 CDI 2041 wiring question - lights?

> Romas Parker Wrote:

> -------------------------------------------------------

> Are you still active on this forum? I have some questions about the

> Pietcard set up I was hoping you could answer. Thanks!

What's the questions?

Re: V1 CDI 2041 wiring question - lights?

Start a new thread with your new pietcard question. Unless it is about the lights which was answered above.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account