Hobbit belt slip at 45

Terbo Speghetti /

So I've tried all the different belts, including the Mitsuboshi OEM one from treats, and I still slip when I hit around 43-5mph. I've still got loootttsss of RPMs left to go. I can tell because the engine revs way out as soon as it slips, and my ear dyno says I'm maybe 2/3 of the way thru the pipe. As soon as I let off the throttle, I can feel it hook right back up and I can accelerate for a sec until it happens again.

Bike setup is polini kit / oko 24 / Vforce / TJT / DOS ramp plate / simo calibrata pipe

What are you 60mph Hobbit people doing? Ramp plate spacers? Grinding out rivets in the pulley?

Give up your secrets plz!(edited)

Re: Hobbit belt slip at 45

Terbo Speghetti /

My only current theory is that my stock contra is tired and gives TOO much, so there's space for the belt to slip. But maybe that's crazy, I dunno.(edited)

Re: Hobbit belt slip at 45

ramp plate spacer for sure, but wheres your wheel adjusted to? Are you sitting 1-2mm below the rear pulley?

Re: Hobbit belt slip at 45

Terbo Speghetti /

I've set it both at the end and 2mm deep. With all the different belts.

Re: Hobbit belt slip at 45

Strong engine with a weak contra will slip a belt

Re: Hobbit belt slip at 45

Terbo Speghetti /

> JBOT Admin Wrote:

> -------------------------------------------------------

> Strong engine with a weak contra will slip a belt

Right on, thanks for confirming my suspicion. Don't remember where I read it, but I recall you saying the red and yellow contras on treats are too girthy when compressed. Am I stuck with a stock replacement?

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account