Am I doing something wrong? -- Top speed

Ok my 78 Magnum XK is modified like crazy. My goal is to cruze at 40 mph (not risking any bearings or wear). With that, I would assume the top speed should be about 50-55. Currently does 47ish, which i cant complain about, but it has 18x40 gearing, which seems to me, according to forums, is very fast. The takeoff is really damn good, I'm not complaining about the acceleration at all. SO ... what steps should I take... even smaller rear sprocket? Carb tuning? Timing? (BTW the timing seems pretty damn good but im no expert)

Spec list:

E50

Stuffy race crank

Treats CDI

Treats kit 70cc

Hi Comp head

21mm OKO

Techno Bullet exhaust

MLM intake

Thanks!

Re: Am I doing something wrong? -- Top speed

Get an exhaust with a bigger expansion chamber. That exhaust is fine for lightly modified, or on a stock cylinder, but for what you want, get something beefier.

MLM pipe, estoril, treats pipe

Re: Am I doing something wrong? -- Top speed

> Danny Lyerla Wrote:

> -------------------------------------------------------

> Get an exhaust with a bigger expansion chamber. That exhaust is fine for

> lightly modified, or on a stock cylinder, but for what you want, get

> something beefier.

>

> MLM pipe, estoril, treats pipe

Re: Am I doing something wrong? -- Top speed

Overpriced Parts /

To high of gearing and crummy exhaust

Re: Am I doing something wrong? -- Top speed

yeah that speed is just about spot on for that setup

most people on the forums lie about their speed to the tune of 5-10 mph, so if you are using actual speed you will be bummed. its way easier to just say you are going 55 than actually go 55. 55 is pretty fast on a moped.

the treats 70 with a basic pipe like a bullet isn't gonna do much

yer gearing is dumb high, 16x40 will feel a lot better, that setup you basically want stock gearing.

i dunno about that oko 21, its the one piece of the puzzle that don't make sense to me. generally i like the keihn clones but some of them have weird tuning parts in them which dont run good on piston ports and can be tough for first timers to tune. I'm not gonna tell you to go out and buy a new carb but a PHBG 19 would make more sense on that setup and there is lots of good info out there on how to tune them.

but yeah, your top speed if its real, is spot on, if you're lying and adding 5 mph thats a bummer. gear down and you might find some speed. you literally bought a bucket of the cheapest puch performance parts you can find, if its actually going 47 and runs well you should be happy.

Re: Am I doing something wrong? -- Top speed

My buddy has a very similar set up. 18x42 gearing, del 21 carb, estoril pipe. His bike runs around 45mph. If you dont have sealed bearings in your rims already its something you can consider. I felt like it added a bit of speed to my set up after switching from loose bearing wheels. (edited)

Re: Am I doing something wrong? -- Top speed

My e50 goes 45 when running without an air filter. As long as you don't ride on dusty lanes or in sand and stay on only clean asphalt roads you can run with no filter (keep your side covers on tho). With a metal mesh filter I only get to 40ish. This is with 70cc kstar, 16/42 gears and 15mm intake/15 bing

Re: Am I doing something wrong? -- Top speed

Wesley Ambrosini /

> Thomas Peffer Wrote:

> -------------------------------------------------------

> My e50 goes 45 when running without an air filter. As long as you don't

> ride on dusty lanes or in sand and stay on only clean asphalt roads you

> can run with no filter (keep your side covers on tho). With a metal mesh

> filter I only get to 40ish. This is with 70cc kstar, 16/42 gears and

> 15mm intake/15 bing

If you down jetted and put back on your air filter it would be exactly the same speed.

Re: Am I doing something wrong? -- Top speed

Dirty30 Dillon /

Lol-ing at "only ride down clean asphalt roads".

Or you could just tune for a filter and ride wherever you want.

Re: Am I doing something wrong? -- Top speed

> Wesley Ambrosini Wrote:

> -------------------------------------------------------

> > Thomas Peffer Wrote:

>

> > -------------------------------------------------------

>

> > My e50 goes 45 when running without an air filter. As long as you

> don't

>

> > ride on dusty lanes or in sand and stay on only clean asphalt roads

> you

>

> > can run with no filter (keep your side covers on tho). With a metal

> mesh

>

> > filter I only get to 40ish. This is with 70cc kstar, 16/42 gears and

>

> > 15mm intake/15 bing

>

> If you down jetted and put back on your air filter it would be exactly

> the same speed.

This. Tune for the filter.

Re: Am I doing something wrong? -- Top speed

Tweaker trash /

> Jake Gnome Wrote:

> -------------------------------------------------------

> My buddy has a very similar set up. 18x42 gearing, del 21 carb, estoril

> pipe. His bike runs around 45mph. If you dont have sealed bearings in

> your rims already its something you can consider. I felt like it added a

> bit of speed to my set up after switching from loose bearing wheels.

Yea that’s dead on (uncased match)

Re: Am I doing something wrong? -- Top speed

> Thomas Peffer Wrote:

> -------------------------------------------------------

> clean asphalt roads

There is no such thing . Not even freshly surfaced is clean enough .

Re: Am I doing something wrong? -- Top speed

You guys were right! I down jetted from a 78 jet to a 74 and put back on the metal mesh filter and my speed jumped back up to a gps'd 47...it buried the stock 40mph speedo all the way to the "P" (pointing upside down) and was still pulling at 3/4 throttle. Flat road no wind. I let off at that point because I'm assuming the bike still has a stock crank.

Re: Am I doing something wrong? -- Top speed

But is it lean now? Do you have a temp gauge?

Re: Am I doing something wrong? -- Top speed

Yes I always run with a temp gauge. Temps always stay below 350F

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account